Amilo Pa1510

Für 899 Euro verkaufte die Büroartikel-Kette “Staples” Anfang Dezember 2006 diesen Laptop. Ich ersetzte M$’s Windows XP® zunächst durch openSUSE-Linux 10.2. Im Dezember 2008 aktualisierte ich das System durch Neuinstallation auf openSUSE-Linux 11.1.

Überlick über die Hardware des Fujitsu Siemens Amilo Pa1510

Prozessor: AMD Turion™ 64 X2 Mobile Technology TL-52 (64-Bit-Doppelkernprozessor, 1,6 GHz-Taktfrequenz, 2x512kB L2-Cache, 31 Watt Leistungsaufnahme); Arbeitsspeicher: 2048 MB DDR-RAM; Festplatte: 120 GB S-ATA (WD1200BEVS-0); Mainboard: ATI X1100 Chipsatz; Grafikkarte: auf dem Mainboard integrierter Radeon XPRESS 200M 5975 (PCIE) Chipsatz mit 128 MB Hauptspeichernutzung; LCD-Monitor: 15,4-Zoll 16:9-Bildformat mit 1200×800 Bildpunkten Auflösung (WXGA) und 60 Hz Bildwiederholfrequenz; Akku: Lithium-Ionen-Akku mit 4000 Milliamperestunden Kapazität (Laufzeit ca. 3 Stunden);Netzteil: 20 Volt / 65 Watt optisches Laufwerk: HL-DT-ST DVDRAM GSA T10-N (DVD-Brenner); On-board-Sound: ATI SB450 mit Realtek AC861-Soundchip (Intel HDA-Soundtreiber); Schnittstellen: Ethernet, externer Monitor/Beamer, 3xUSB 2.0, FireWire (IEEE 1394), Speicherkartenlesr, S-Video-Fernsehanschluss; WLAN: Atheros AR5005G (onboard 802.11g); Bluetooth: Broadcom CCBT2035BDGP23-1 (USB-Stick).

Partitionierung der Festplatte

Bei der Installation habe ich folgende Partitionierung gewählt: sda1 22,25 GB Root-Verzeichnis, sda2 5,25 GB Swap-Partition, sda3 50 GB Home-Verzeichnisse (verschlüsselt), sda4 33,75 GB für Betriebssystem-Emulationen (Apple MaxOS 7.x, DOS 6.22, WfW 3.11, WinNT4, WinXP, OS2/Warp), Ich habe alle Partitionen mit dem Partitionierungswerkzeug von YaST während der Basisinstallation angelegt und mit dem ext3-Dateisystem formatiert.

Grundinstallation von openSUSE Linux 11.1

Zur Installation habe ich die DVD gestartet (ISO-Image von der Download-Seite von openSUSE, gebrannt mit k3b unter openSUSE-Linux 11.0). Danach einfach den Installationsanweisungen folgen (Partitionierung siehe oben). Am Ende der Grundinstallation hat man ein funktionierendes System mit Kernel 2.6.27.7-9-default, X.org 7.4 und KDE 4.1.3. Später eingebunden habe ich das KDE-Factory-Repository (KDE 4.2) und einige Software-Repositories (Packman, ViedoLAN, openOffice.org, Spiele, Datenbanken). 3D-Grafik erhält man durch Einbinden des ATI-Repositories. WLAN funktioniert out-of-the-box mit dem ath5k-Treiber.

Weitere Anpassungen

Nokia-N70-Mobiltelefon als UMTS-Modem: Ich benutze das Mobiltelefon über die Bluetooth-Schnittstelle (USB-Stick). In die Datei /etc/init.d/boot.local muss folgender Befehl eingetragen werden: rfcomm bind /dev/rfcomm0 00:11:22:33:44:55 3. Dabei ist 00:11:22:33:44:55 die MAC-Adresse des Handys, die man mit hcitool scan erhält. 3 ist die Kanalnummer des rfcomm-Kanals, die man mit sdptool browse 00:11:22:33:44:55 prüfen sollte (dazu muss am Handy Bluetooth eingeschaltet und für alle Geräte sichtbar sein – letzteres ist Später nicht mehr nötig.) Mit der YaST-Modemeinstellung lässt sich das Modem dann konfigurieren: Einfach in den Modemparametern die Schnittstelle /dev/rfcomm0 eintragen. Bei “Details” wird die Baudrate 115200 und folgende zusätzlichen init-Strings eingetragen: init2 AT S7=45 S0=0 V1 X4 &c1 E0 und init 3 AT+CGDCONT=1,”IP”,”surfo2″ (init 2 habe ich aus einer Handyanleitung im Internet, init3 ist die UMTS-/GPRS-Initstring-Angabe meines Providers O2). Außerdem muss noch “Benutzergesteuert” angekreuzt werden. Anschließend müssen noch die Providerdaten eingetragen werden. Für fast alle Provider gilt dabei die Telefonnummer *99***1# Allerdings fehlt nun noch die Bluetooth-Pin zum Koppeln von PC (bzw. USB-Stick) und Handy. Dazu müssen die bluez-gnome-Pakete installiert und in der Konsolle der Bluetooth-Wizard gestartet werden. Dieser zeigt dann die PIN an, die am Handy einzugeben ist. Um mit Kinternet dann die UMTS-Verbindung herstellen zu können ist es noch nötig, die DNS-Daten des Providers (193.189.244.205 und 193.189.244.197 bei O2) einzugeben. Dies geschieht mit dem YaST2-Sysconfig-Editor unter Network-General im Wert NETCONFIG_DNS_STATIC_SERVERS. Zur Sicherheit und um Probleme mit dem WLAN zuhause zu verhindern habe ich dort als dritten Wert noch die IP meines WLAN-Routers (192.168.2.1) eingetragen. Schließlich habe ich noch folgende Werte gesetzt: DHCLIENT_RELEASE_BEFORE_QUIT=yes und DHCLIENT_USE_LAST_LEASE=no. Damit waren alle Bluetooth-PIN und DNS-Probleme beseitigt, die durch die seit openSUSE 11.0 erfolgen Änderungen am Bluetooth-System entstanden waren.
Sound: Zwar funktioniert der Sound gleich bei der Installation. Es kann allerdings nicht über den Mikrofoneingang aufgenommen werden (alsa 1.0.17). HELP WANTED!!!